@wordpress/babel-preset-default

Default Babel preset for WordPress development.

Usage no npm install needed!

<script type="module">
  import wordpressBabelPresetDefault from 'https://cdn.skypack.dev/@wordpress/babel-preset-default';
</script>

README

Babel Preset Default

Default Babel preset for WordPress development.

The preset includes configuration which enable language features and syntax extensions targeted for support by WordPress. This includes ECMAScript proposals which have reached Stage 4 ("Finished"), as well as the JSX syntax extension. For more information, refer to the JavaScript Coding Guidelines.

Installation

Install the module

npm install @wordpress/babel-preset-default --save-dev

Note: This package requires Node.js 12.0.0 or later. It is not compatible with older versions.

Usage

There are a number of methods to configure Babel. See Babel's Configuration documentation for more information. To use this preset, simply reference @wordpress/babel-preset-default in the presets option in your Babel configuration.

For example, using .babelrc:

{
    "presets": [ "@wordpress/babel-preset-default" ]
}

Extending Configuration

This preset is an opinionated configuration. If you would like to add to or change this configuration, you can do so by expanding your Babel configuration to include plugins or presets which override those included through this preset. It may help to familiarize yourself the implementation of the configuration to see which specific plugins are enabled by default through this preset.

For example, if you'd like to use a new language feature proposal which has not reached the stability requirements of WordPress, you can add those as additional plugins in your Babel configuration:

{
    "presets": [ "@wordpress/babel-preset-default" ],
    "plugins": [ "@babel/plugin-proposal-class-properties" ]
}

Polyfill

There is a complementary build/polyfill.js (minified version – build/polyfill.min.js) file available that polyfills ECMAScript features missing in the browsers supported by the WordPress project (#31279). It's a drop-in replacement for the deprecated @babel/polyfill package, and it's also based on core-js project.

This needs to be included before all your compiled Babel code. You can either prepend it to your compiled code or include it in a <script> before it.

TC39 Proposals

If you need to use a proposal that is not Stage 4, this polyfill will not automatically import those for you. You will have to import those from another polyfill like core-js individually.



Code is Poetry.