@wordpress/edit-site

Edit Site Page module for WordPress.

Usage no npm install needed!

<script type="module">
  import wordpressEditSite from 'https://cdn.skypack.dev/@wordpress/edit-site';
</script>

README

Edit Site

Edit Site Page Module for WordPress.

This package is meant to be used only with WordPress core. Feel free to use it in your own project but please keep in mind that it might never get fully documented.

Installation

npm install @wordpress/edit-site

Usage

/**
 * WordPress dependencies
 */
import { initialize } from '@wordpress/edit-site';

/**
 * Internal dependencies
 */
import blockEditorSettings from './block-editor-settings';

initialize( '#editor-root', blockEditorSettings );

This package assumes that your code will run in an ES2015+ environment. If you're using an environment that has limited or no support for such language features and APIs, you should include the polyfill shipped in @wordpress/babel-preset-default in your code.

Contributing to this package

This is an individual package that's part of the Gutenberg project. The project is organized as a monorepo. It's made up of multiple self-contained software packages, each with a specific purpose. The packages in this monorepo are published to npm and used by WordPress as well as other software projects.

To find out more about contributing to this package or Gutenberg as a whole, please read the project's main contributor guide.



Code is Poetry.