eslint-plugin-censor

The plugin will prevent you from using swear pejoratives and abuse words.

Usage no npm install needed!

<script type="module">
  import eslintPluginCensor from 'https://cdn.skypack.dev/eslint-plugin-censor';
</script>

README

eslint-plugin-censor

The plugin will prevent you from using swear pejoratives and abuse words.

Version Bundle size Downloads

CodeFactor SonarCloud Codacy Total alerts Language grade Scrutinizer

Dependencies Security Build Status Coverage Status

Commit activity FOSSA License

Table of Contents

Requirements

Platform Status

To use library you need to have node and npm installed in your machine:

  • node >=10
  • npm >=6

Package is continuously tested on darwin, linux, win32 platforms. All active and maintenance LTS node releases are supported.

Installation

To install the library run the following command

  npm i --save-dev eslint-plugin-censor

Usage

After installation, add plugin to eslint config:

{
    "extends": [...],
    "env": {...},
    "plugins": [ "censor" ],
    "rules": {...}
}

And enable rule:

{
    "extends": [...],
    "env": {...},
    "plugins": [ "censor" ],
    "rules": {
      ...
      "censor/no-swear": 2
    }
}

Now you can check your courtesy by running eslint.

Sources

Contribute

Make the changes to the code and tests. Then commit to your branch. Be sure to follow the commit message conventions. Read Contributing Guidelines for details.