@ipscape/ckeditor5-build

The ipSCAPE custom build of CKEditor 5.

Usage no npm install needed!

<script type="module">
  import ipscapeCkeditor5Build from 'https://cdn.skypack.dev/@ipscape/ckeditor5-build';
</script>

README

ipSCAPE - CKEditor 5 custom build

Quick start

First, install the build from npm:

npm install --save @ipscape/ckeditor5-build

or

yarn add @ipscape/ckeditor5-build

And use it in your website:

<div id="editor">
  <p>This is the editor content.</p>
</div>
<script src="./node_modules/@ipscape/ckeditor5-build/build/ckeditor.js"></script>
<script>
  ClassicEditor.create(document.querySelector("#editor"))
    .then((editor) => {
      window.editor = editor;
    })
    .catch((error) => {
      console.error("There was a problem initializing the editor.", error);
    });
</script>

Or in your JavaScript application:

import ClassicEditor from "@ipscape/ckeditor5-build";

// Or using the CommonJS version:
// const ClassicEditor = require( '@ipscape/ckeditor5-build' );

ClassicEditor.create(document.querySelector("#editor"))
  .then((editor) => {
    window.editor = editor;
  })
  .catch((error) => {
    console.error("There was a problem initializing the editor.", error);
  });

Extract css styles

https://ckeditor.com/docs/ckeditor5/latest/builds/guides/integration/advanced-setup.html#option-minifying-javascript

Build project

yarn build

Check /sample/index.html for testing the new build.

License

Licensed under the terms of GNU General Public License Version 2 or later. For full details about the license, please check the LICENSE.md