File system persister for @pollyjs

Usage no npm install needed!

<script type="module">
  import pollyjsAdapterPuppeteer from 'https://cdn.skypack.dev/@pollyjs/adapter-puppeteer';



Record, Replay, and Stub HTTP Interactions

Build Status npm version license

The @pollyjs/adapter-puppeteer package provides a Puppeteer adapter to be used with @pollyjs/core.


If you're using puppeteer 1.7 or 1.8, you'll experience issues with passthrough requests. Please upgrade to the latest version of puppeteer or use a version prior to 1.7

Note that you must have node (and npm) installed.

npm install @pollyjs/adapter-puppeteer -D

If you want to install it with yarn:

yarn add @pollyjs/adapter-puppeteer -D


Check out the Puppeteer Adapter documentation for more details.


import { Polly } from '@pollyjs/core';
import PuppeteerAdapter from '@pollyjs/adapter-puppeteer';


const browser = await puppeteer.launch();
const page = await this.browser.newPage();

await page.setRequestInterception(true);

new Polly('<Recording Name>', {
  adapters: ['puppeteer'],
  adapterOptions: {
    puppeteer: { page }

await page.goto('https://netflix.com');


Copyright (c) 2018 Netflix, Inc.

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at


Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.