@wordpress/primitives

WordPress cross-platform primitives.

Usage no npm install needed!

<script type="module">
  import wordpressPrimitives from 'https://cdn.skypack.dev/@wordpress/primitives';
</script>

README

Primitives

Primitives to be used cross-platform.

Installation

Install the module

npm install @wordpress/primitives --save

Usage

import { SVG, Path } from '@wordpress/primitives';

const myElement = (
    <SVG
        width="18"
        height="18"
        viewBox="0 0 18 18"
        xmlns="http://www.w3.org/2000/svg"
    >
        <Path d="M4.5 9l5.6-5.7 1.4 1.5L7.3 9l4.2 4.2-1.4 1.5L4.5 9z" />
    </SVG>
);

This package assumes that your code will run in an ES2015+ environment. If you're using an environment that has limited or no support for such language features and APIs, you should include the polyfill shipped in @wordpress/babel-preset-default in your code.



Code is Poetry.